BSD-3-Clause licensed by Aden Grue

Module documentation for 0.1.2.8

This version can be pinned in stack with:proto-lens-arbitrary-0.1.2.8@sha256:4afde72fa0dc95011c778567077785584021526c3a93ac1ea44506d9ea180d69,1273

The proto-lens-arbitrary allows generating arbitrary messages for use with QuickCheck.

Changes

Changelog for proto-lens-arbitrary

v0.1.2.8

  • Bump lower bounds to base-4.10 (ghc-8.2).
  • Bump upper bounds for proto-lens-0.6.
  • Support dependencies on base-4.13 (ghc-8.8) and lens-family-2.0.

v0.1.2.7

  • Bump the dependency for QuickCheck-2.13.

v0.1.2.6

  • Bump upper bounds to support proto-lens-0.5.*.

v0.1.2.5

  • Bump the dependency for QuickCheck-2.12.

v0.1.2.4

  • Bump the dependencies on base and containers to support ghc-8.6.1.

v0.1.2.3

  • Update to (and require) proto-lens-0.4.*.

v0.1.2.2

  • Bump the lower bound on base to indicate we require ghc>=8.0.

v0.1.2.1

  • Bump the dependency on base for ghc-8.4.2.
  • Bump the dependency for QuickCheck-2.11.

v0.1.2.0

  • Remove support for ghc-7.10. (#136)
  • Use a .cabal file that’s auto-generated from hpack. (#138)
  • Track proto-lens changes to the Message class. (#139, #147)
  • Expose shrinkMessage (#159)
  • Improve the Arbitrary generator for nested structures (#163)

v0.1.1.1

  • Bump the dependency on base to support ghc-8.2.1.

0.1.1.0

  • Export the arbitraryMessage function (#93).

0.1.0.3

  • Bump the dependency for QuickCheck-2.10.
  • Make the build -Wall-clean.

0.1.0.2

  • Bump the dependency for QuickCheck-2.9.

0.1.0.1

  • Bump the dependency on base to support ghc-8.0.

0.1.0.0

Initial version.

comments powered byDisqus