pipes-aeson

Encode and decode JSON streams using Aeson and Pipes. https://github.com/k0001/pipes-aeson

Version on this page:0.4.1.4
LTS Haskell 7.24:0.4.1.8
Stackage Nightly 2017-08-20:0.4.1.8
LTS Haskell 7.24:0.4.1.8
Stackage Nightly 2017-08-20:0.4.1.8
Latest on Hackage:0.4.1.8
BSD3 licensed by Renzo Carbonara
Maintained by renzocarbonaraλgmail.com

Module documentation for 0.4.1.4

pipes-aeson

Utilities to encode and decode streams of JSON values using Pipes and Aeson.

Check the source or rendered Haddocks for documentation.

This code is licensed under the terms of the so called 3-clause BSD license. Read the file named LICENSE found in this same directory for details.

See the PEOPLE file to learn about the people involved in this effort.

Changes

0.4.1.8

  • Remove upper bound dependencies on everything but base.

0.4.1.7

  • Raise upper bound dependency on aeson.

  • Raise upper bound dependency on pipes.

0.4.1.6

  • Raise upper bound dependency on aeson.

  • Raise upper bound dependency on transformers.

0.4.1.5

  • Raise upper bound dependency on aeson.

0.4.1.4

  • Raise upper bound dependency on aeson.

0.4.1.3

  • Raise upper bound dependency on attoparsec.

0.4.1.2

  • Raise upper bound dependency on aeson.

0.4.1.1

  • Raise upper bound dependency on pipes-bytestring.

0.4.1

  • Raise upper bound dependency on attoparsec.

0.4

  • Remove Pipes.Aeson.encode in favour of encodeObject and encodeArray.

  • decode and decodeL now return Nothing on end of input, instead of failing with a DecodingError. This follows the approach taken by pipes-attoparsec-0.5.

  • Solved quadratic time complexity issue when decoding (#10).

  • Depend on pipes-attoparsec-0.5.*.

  • Raise upper bound for transformers to 0.4.*.

0.3.0

  • API revamped to be compatible with pipes-parse-3.0.*.

  • Renamed Pipes.Aeson.Unsafe module to Pipes.Aeson.Unchecked.

0.2.1

  • Generalize encode from Producer to Producer'.

  • Depend on newer versions of aeson, attoparsec, pipes-attoparsec.

0.2.0

  • Version compatible with pipes-4.0.0 and pipes-parse-2.0.0.

  • API radically changed. Removed parseValue, fromValue and TopLevelValue. Other things renamed.

0.1.0.0

  • First version.
comments powered byDisqus