engine-io-snap

http://github.com/ocharles/engine.io

Latest on Hackage:1.0.5

This package is not currently in any snapshots. If you're interested in using it, we recommend adding it to Stackage Nightly. Doing so will make builds more reliable, and allow stackage.org to host generated Haddocks.

BSD3 licensed by Oliver Charles
Maintained by ollie@ocharles.org.uk

This package provides an engine-io ServerAPI that is compatible with Snap.

Changes

1.0.5

  • Bump upper-bound of base, io-streams and websockets

1.0.4

  • Increased the upper-bound of base, snap-core, websockets and websockets-snap.
  • Snap 1.0 is now required.
  • Use lifted-base instead of MonadCatchIO-transformers.

1.0.3

  • Increased the upper-bound of base to allow < 4.9. Now builds on GHC 7.10.1.

1.0.2

  • Updated for ServerAPI in engine-io-1.2.

  • ParseError is now caught correctly, and no longer results in a response 500 to the client.

1.0.1

  • Updated for the new ServerAPI in engine-io-1.1.

  • Fixed incomplete pattern matches when parsing request method.

1.0.0

  • Initial release.
comments powered byDisqus