transformers-compat

A small compatibility shim exposing the new types from transformers 0.3 and 0.4 to older Haskell platforms. http://github.com/ekmett/transformers-compat/

Version on this page:0.3.3.3
LTS Haskell 15.14:0.6.5
Stackage Nightly 2020-05-26:0.6.5
Latest on Hackage:0.6.5

See all snapshots transformers-compat appears in

BSD-3-Clause licensed by Edward A. Kmett
Maintained by Edward A. Kmett

Module documentation for 0.3.3.3

This version can be pinned in stack with:[email protected]:3f2c51a52011b24f6b979e4a18c5fb76d62af7e432ec728201967b35894bf0b1,2302

There are no documented modules for this package.

transformers-compat

Build Status

This provides a thin compatibility shim on top of transformers-0.2 to add the types that were added in transformers-0.3.

This enables users to maintain haskell-platform compatibility, while still gaining access ot the new functionality.

Contact Information

Contributions and bug reports are welcome!

Please feel free to contact me through github or on the #haskell IRC channel on irc.freenode.net.

-Edward Kmett

Changes

0.3.1

  • transformers 0.4.1 compatibility

0.3

  • Added the instances for Data.Functor.Classes from transformers 0.4
  • Switched Control.Applicative.Backwards and Data.Functor.Reverse to the split constructor/accessor style from transformers 0.4.

0.2

  • Added the new types and classes from transformers 0.4

0.1.1.1

  • Wrote a better synopsis

0.1.1

  • Updated to trick cabal into building an empty libHStransformers-compat-0.1.a on GHC 7.6.

0.1

  • Repository initialized by pulling the transformers-0.2 compatibility layer out of lens.