BSD-3-Clause licensed by Andrew Pritchard

Module documentation for 0.1.1.6

This version can be pinned in stack with:proto-lens-optparse-0.1.1.6@sha256:f8ac53d7293b3c566a23b0999f20a314d8b5188d75ccd6d441c7323936ab3c00,1275

A package adapting proto-lens to optparse-applicative ReadMs. This gives an easy way to define options and arguments for text-format protobuf types.

Changes

Changelog for proto-lens-optparse

v0.1.1.6

  • Bump lower bounds to base-4.10 (ghc-8.2).
  • Support dependencies on base-4.13 (ghc-8.8) and optparse-applicative-0.15.
  • Bump upper bounds for proto-lens-0.6.

v0.1.1.5

  • Bump the upper bound to proto-lens-0.5.*.

v0.1.1.4

  • Bump the dependency on base to support ghc-8.6.1.

v0.1.1.3

  • Bump the upper bound to proto-lens-0.4.

v0.1.1.2

  • Bump the lower bound on base to indicate we require ghc>=8.0.

v0.1.1.1

  • Bump the dependency on base for ghc-8.4.2.

v0.1.1.0

  • Add MessageEnum ReadM and option builders (#181).

v0.1.0.5

  • Remove support for ghc-7.10. (#136)
  • Use a .cabal file that’s auto-generated from hpack. (#138)

v0.1.0.4

  • Bump the dependency on base to support ghc-8.2.1.

v0.1.0.3

  • Bump the dependency for optparse-applicative-0.14.

v0.1.0.2

  • Bump the dependencies for optparse-applicative-0.13 and proto-lens-0.2.

v0.1.0.1

  • Bump the dependency on base to support ghc-8.0.

v0.1.0.0

Initial version.

comments powered byDisqus