Deprecated

fay-builder

Compile Fay code on cabal install, and ad-hoc recompile during development

LTS Haskell 8.24:[email protected]:4
Stackage Nightly 2017-06-26:[email protected]:4
Latest on Hackage:[email protected]:4

See all snapshots fay-builder appears in

BSD-3-Clause licensed by Silk B.V.
Maintained by [email protected]

Module documentation for 0.2.0.5

This version can be pinned in stack with:[email protected]:75a6193b829d2d606a20782ca37f4ee8f02baa91d8f49f989e820e51710e3d26,1178

fay-builder

Build Status

For an introduction please see the post on the Silk Engineering blog.

Installation

fay-builder is available on Hackage, to install it:

cabal install fay-builder

Changes

Changelog

0.2.0.5

  • Allow Cabal < 1.24

0.2.0.4

  • Allow base 4.8.* and filepath 1.4.*

0.2.0.3

  • Allow fay 0.23.*.

0.2.0.2

  • Allow fay 0.22.*.

0.2.0.1

  • Allow fay 0.21

0.2

  • Add flag x-fay-strict-modules, specifying modules that should get a strict wrapper.
  • Add flag x-fay-library, indicating that no main function should be called.
  • Export new readField function.
  • Signature for fayConfig has changed.
  • Clarify license as BSD3.

0.1.0.7 (2014-04-29)

  • Use fay 0.20

0.1.0.5

  • Initial release