haskell-gi-overloading

Overloading support for haskell-gi https://github.com/haskell-gi/haskell-gi

Version on this page:1.0
LTS Haskell 9.18:1.0
Stackage Nightly 2017-12-10:1.0
Latest on Hackage:1.0
BSD3 licensed by Iñaki García Etxebarria
Maintained by garetxe@gmail.com

Module documentation for 1.0

There are no documented modules for this package.

Bindings generated by haskell-gi are by default compiled with support for OverloadedLabels.

This support for OverloadedLabels comes at a cost in compile time, which can be significant in some cases. For convenience, this support can be switched off in programs using haskell-gi generated bindings, which do not require overloading support, by making them depend (in the build-depends field of the cabal file) on haskell-gi-overloading == 0.0.*.

Changes

Variants of haskell-gi-overloading

1.0

  • Enable support for overloading.

0.0

  • Disable support for overloading.
comments powered byDisqus