BSD-3-Clause licensed by Jonathan Fischoff, Moritz Kiefeir, Leo P. Smith

Module documentation for 0.2.0.0

This version can be pinned in stack with:postgresql-libpq-notify-0.2.0.0@sha256:bbc4340400dcd788eaea238b5e7a64abe6046f84b1ba0a333384512cf081ec8c,1365

postgresql-libpq-notify

build status

postgresql-libpq-notify is a low level and minimal dependency PostgreSQL notification library.

It is meant to provide support for higher level PostgreSQL libraries based on postgresql-libpq such as squeal or hasql.

It is based work by Moritz Kiefeir and Leo P. Smith.

Changes

  • 0.2.0.0
    • #6 Simplify interface because the race is impossible to prevent unless the connection is held until getNotification returns.
  • 0.1.0.0 First version
Used by 1 package in nightly-2020-10-18(full list with versions):