prettyprinter-compat-wl-pprint

Prettyprinter compatibility module for previous users of the wl-pprint package.

http://github.com/quchen/prettyprinter

Version on this page:1.0.0.1@rev:1
LTS Haskell 17.10:1.0.0.1@rev:3
Stackage Nightly 2021-05-09:1.0.0.1@rev:3
Latest on Hackage:1.0.0.1@rev:3

See all snapshots prettyprinter-compat-wl-pprint appears in

BSD-2-Clause licensed by Daan Leijen, Noam Lewis, David Luposchainsky
Maintained by David Luposchainsky <dluposchainsky at google>
This version can be pinned in stack with:prettyprinter-compat-wl-pprint-1.0.0.1@sha256:e62f6303842be0c8b2e966765d965f45fe9778c96619f6f1a9e3b27b62d5cc37,1257

Module documentation for 1.0.0.1

wl-pprint compatibility package

This package defines a compatibility layer between the old wl-pprint package, and the new prettyprinter package.

This allows easily transitioning dependent packages from the old to the new package, by simply replacing wl-pprint with prettyprinter-compat-wl-pprint in the .cabal file.

Note that this package is only for transitional purposes, and therefore deprecated and wholly undocumented. For new development, use the current version of prettyprinter.