yesod-auth-account

An account authentication plugin for Yesod https://bitbucket.org/wuzzeb/yesod-auth-account

Version on this page:1.4.3
LTS Haskell 9.9:1.4.3
Stackage Nightly 2017-07-25:1.4.3
Latest on Hackage:1.4.3
MIT licensed and maintained by John Lenz

Module documentation for 1.4.3

This package provides a Yesod authentication plugin for accounts. Each account consists of an username, email, and password. When initially creating an account, the email is verified by sending a link in an email. The plugin also supports password reset via email.

The plugin provides default pages implementing all of this functionality, but it has been designed to allow all the pages (new account page, password reset, etc.) to be customized or for the forms to be embedded into your own pages allowing you to just ignore the routes inside the plugin. The details are contained in the haddock documentation.

The plugin supports any form data storage by requiring you to implement a couple of interfaces for data access. The plugin has instances of these interfaces using persistent, but you can create your own implementation if you are not using persistent or want more control over user data access and storage.

A complete working example using persistent is example.hs. Also, see the haddock documentation.

Changes

1.4.2

  • Allow persistent 2.5

1.4.1

  • Allow newest version of persistent
  • Fix some warnings in the test suite

1.4.0

  • Add proper support for i18n:
    • Moved messages into Yesod.Auth.Account.Message module
    • Added renderAccountMessage function to YesodAuthAccount class, which defaults to the english messages.
    • resendVerifyEmailWidget, resetPasswordWidget, newAccountForm, resetPasswordForm, and runAccountPersistDB had their context's updated with a constraint for YesodAuthAccount db master, which shouldn't be a problem.
  • Use the nonce package for generating the keys sent in the verification and reset password emails. The nonce package provides efficient and cryptographically secure nonces.

  • Support yesod 1.4 and persistent 2.1 (also bump our version to 1.4 to match yesod)

comments powered byDisqus