packdeps

Check your cabal packages for lagging dependencies. http://packdeps.haskellers.com/

Version on this page:0.4.3
LTS Haskell 9.18:0.4.3
Stackage Nightly 2017-12-16:0.4.4
Latest on Hackage:0.4.4
BSD3 licensed and maintained by Michael Snoyman

Module documentation for 0.4.3

packdeps

Build Status

Check the upper bounds on a package to determine if there are newer versions of dependencies.

Changes

0.4.4

  • Switch over to Cabal 2.0. (Normally it would be better to keep backwards compat, but the API breakage is too high.)

0.4.3

  • Updates (better cabal config parsing) #30

0.4.2

  • Added --quiet flag to suppress output for up to date cabal files #29

0.4.1

  • Cli improvements: UI tweaks and --recursive flag #28
comments powered byDisqus