BSD-3-Clause licensed
Maintained by [email protected]

Module documentation for 3.2.0.6

This version can be pinned in stack with:[email protected]:9a700458d6ef097fc5093423041670d15669caac633eae4b05d41614758f165a,1346

This package provides a library for parallel programming.

Changes

Changelog for parallel package

3.2.0.6 Dec 2014

  • Make -Wall message free for all supported base versions

3.2.0.5 Dec 2014

  • Support base-4.8.0.0/deepseq-1.4.0.0 (and thus GHC 7.10)

3.2.0.4 Nov 2013

  • Update package description to Cabal 1.10 format
  • Add support for GHC 7.8
  • Drop support for GHCs older than GHC 7.0.1
  • Add NOINLINE pragmas to parBuffer, parList, and evalBuffer to make RULEs more likely to fire