BSD-3-Clause licensed by Gabriel Gonzalez
Maintained by Gabriel439@gmail.com
This version can be pinned in stack with:mmorph-1.1.4@sha256:d49384befd4170d9b8ce190e2b860f832f1b18af93f9c7231f44187f1d937c77,1069

Module documentation for 1.1.4

This library provides monad morphism utilities, most commonly used for manipulating monad transformer stacks.

Changes

1.1.4

  • Fix MonadFail-related code to work for GHCJS

1.1.3

  • Add an MFunctor instance for ComposeT for GHC >= 8.6
  • Add GHC 8.8 support

1.1.2

  • Conditionally disable Polykinds to support older versions of GHC

1.1.1

  • Increase upper bound on transformers-compat

1.1.0

  • BREAKING CHANGE: Enable PolyKinds
    • This should in theory be a non-breaking change, but due to a bug in GHC 8.0.1 and kind inference ambiguities I’m marking this as a breaking change