BSD3 licensed by Dmitry Bushev , Benno Fünfstück

stackage2nix

Build Status

stackage2nix converts a Stack file into a Nix Haskell packages set.

Create build derivation from stack.yaml

Generate targets from stack.yaml only

stack exec -- stackage2nix .

Command creates file default.nix which overrides haskell.packages.stackage packages set. You should use typeable/nixpkgs-stackage overlay that adds LTS Stackage packages to Nixpkgs.

Build package with overlay installed:

nix-build -A stackage2nix

Generate Stackage packages for the build

If you don’t want to use Stackage overlay, stackage2nix can generate required packages with --with-stackage-closure flag.

stack exec -- stackage2nix \
  --all-cabal-hashes /path/to/commercialhaskell/all-cabal-hashes \
  --lts-haskell /path/to/fpco/lts-haskell \
  --with-stackage-closure \
  ./stack.yaml

To generate Stackage packages, you should supply additional --all-cabal-hashes and --lts-haskell flags that points to commercialhaskell/all-cabal-hashes checked out to hackage branch and fpco/lts-haskell respectively.

stackage2nix wrapper

You can use stackage2nix wrapper from nix directory that adds required flags:

nix-env -i -f ./nix/stackage2nix
stackage2nix --with-stackage-closure ./stack.yaml

This command will produce packages.nix and configuration-packages.nix Stackage packages and its override in default.nix

Generate full Stackage

--with-stackage parameter generates full Stackage LTS in addition to the targets from stack.yaml

nix-env -i -f ./nix/stackage2nix
stackage2nix --with-stackage ./stack.yaml

Generate Stackage from LTS resolver

You can also generate only Stackage packages set from the resolver:

nix-env -i -f ./nix/stackage2nix
stackage2nix --resolver lts-10.0

This command will produce Stackage packages packages.nix, packages config configuration-packages.nix and a Haskell packages set default.nix.

Runtime dependencies

  • nix-env is required to be on PATH by the distribution-nixpkgs dependency
  • nix-prefetch-scripts is required on PATH if you have git dependencies in stack.yaml

Override result derivation

Complex projects may require some extra customization. Snippet override.nix below shows a minimal example of how to apply additional overrides on top of Haskell packages set produced by stackage2nix.

with import <nixpkgs> {};
with haskell.lib;
let haskellPackages = import ./. {};
in haskellPackages.override {
  overrides = self: super: {
    stackage2nix = disableSharedExecutables super.stackage2nix;
  };
}
nix-build -A stackage2nix override.nix

For more complex overrides and detailed information on how to work with Haskell packages in Nix, see Nixpkgs manual User’s Guide to the Haskell Infrastructure

Tests

Integration tests that build stackage2nix form different yaml configs:

STACKAGE_REPO=<path/to/stackage/repo> \
ALL_CABAL_HASHES=<path/to/all-cabal-hashes/repo> \
STACK_FILE=stack-ghc-7103.yaml \
./ci-stackage2nix

Changes

0.7.1

  • Generate stack packages stack-yaml-packages.nix

0.7.0

0.6.1

  • Pass extra buildHaskellPackages argument to makePackageSet function

0.6.0

  • Replace call to <nixpkgs/pkgs/development/haskell-modules> in generated Haskell packages with makePackageSet library function

0.5.0

  • Add --with-stackage and --with-stackage-closure flag generates stackage
  • Add --extra-deps-revision-latest flag. Changes generation strategy for the direct dependencies of the stack.yaml extra-deps. Default strategy is to generate exact revision defined in the Stackage config. With this flag enabled, direct dependencies of the stack.yaml extra-deps will be generated with latest revision available on Hackage. This may help when Cabal fails to resolve dependencies of extra-deps, and dependences are fixed in the latest revision
  • Upd by default stackage2nix generates override of pre-generated Stackage packages set.
  • Upd generated Stackage packages with doCheck and runHaddock enabled by default
  • Remove --do-check-stackage flag (enabled by default)
  • Remove --do-haddock-stackage flag (enabled by default)
  • Remove --no-packages-closure flag (use --with-stackage-closure)
  • Remove cabal2nix < 2.7.2 support #45

0.4.0

  • Add --resolver option to generate full stackage packages set
  • Add Nix wrapper, see nix/README.md
  • Upd support cabal2nix >2.5
  • Fix honor --hackage-db flag

0.3.0

  • Initial Hackage release
  • Add CHANGELOG.md
comments powered byDisqus